MicroBlaze Tutoria # 1

For thisfirst tutorial we will set up asimple example using the Digilab DE2 board
with the DIO1 board connected to the A and B connectors. This setup is shown below:

The switches on the DIO1 board are read and output to the LED’s.

Open the Xilinx XPS. Shortcut to XPS_GUI.exe.Ink

Edit View Help

Base System Builder... . =
Open Project | Flatform Studio... I :
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Recent Projects | e R e e Hi— | o ey

Exit
Symbols 1

Select File > New Project - Platform Studio.

Create New Project

i~ Mew Project
The praject file will be created in the current directary if a path iz not specified.

Froject File IE: WAB_TutorialzhT 1 apstem. smp

Esizting MHS to ] Browse ...
Impart [0 ptional]

i~ Target Device -
Architecture Device Size Package Speed Grade

|spartan2& _*f_J JHC232DDE_T_J ]pQEDB__Y_j ]-E _v_j

i~ Peripheral Beposzitory Directory

[ User Peripheral Repository search path for 1P, diver and library files.
Can be a zemicolon separated hst of directonies.

k. Cancel

Specify project file location, spartan2e, xcs2s200e, pg208, speed —6. Click on OK.



Xilinx Platform Studio

You have not specified a MHS file,
! Do you want to start with an empty MHS File
C:\MB_Tutorials\T 1\system. mhs

Click on Yes. Then on OK.



Ps| Xilinx XPS - C:\MB_Tutorials\T1\
File Edit Wiew Project Tools Options Window Help

0 A - R SR e P 2l T

~[Add/Edit Cores (dialog)]
System ]D:-!!ms Symbols |

Rlght Click for Options
El System 5P
=-[F Project Files

E MHE File: spstem.mhz
Bl S5 File: svstemn.mez

Click on * Add/Edit Cores’ icon or select Project - Add/Edit Cores.

Add the following components:
microblaze

bram_block

opb_gpio

opb_gpio

Imb_bram _if cntlr
Imb_bram_if_cntlr
opb_jtag uart

NouokrwdrE

Rename the peripherals Instance name and change the addresses as shown below.

Peripheral HW Ver | Instance Base Address High Address
microblaze 2.00.a mblaze

bram_block 1.00.a braml

opb_gpio 2.00.a gpio_swts Oxfffe0400 Oxfffe05ff
opb_gpio 2.00.a gpio_leds Oxfffe0600 OxfffeQ7ff
Imb_bram_if_cntlr | 1.00.b Imb_d_cntrl 0x00000000 0x00000fff
Imb_bram_if_cntlr | 1.00.b Imb_i_cntrl 0x00000000 0x00000fff
opb_jtag_uart 1.00.b jtag_uart Oxffff8000 Oxffff80ff




Add/Edit Hardware Platform Specifications

Peripherals ] Bus Connections 1 Ports ] Farameters ]

H - ' Calls with white backgrounds can be edited.
Ll | To delete perpheralz, choose one ar more rows and click Delete.

Peripheral HW Ver Instance Base Address | High Address | Min
microblaze 2.00.a _x|mblaze

bram_block 1.00.a

opb_gpio 3.00.a L{gpin_swts Oxfffe0400 | Oxfffedsff Qx 20
opb_gpio 3.00.a3 L{gpin_leds Oxfffe0g0l | Oxfffed7ff 0 20
Imb_bram _i... |1.00.b Imb_d_cntrl 0x00000000 | Ox00000FFF | Oac
mb_bram_i... | .00.b  Imb_i_cnirl 0x00000000 | Ox00000FFF | Oac
opb_jtag_u... | 1.00.b jtag_uart 0xFFFFB000  OxFFFFS0FF

Select the Bus Connections tab, and add one instance of opb_v20 v10 aand two
instances of Imb_v10 v1 00 a. By right clicking rename these to opb, d_Imb, and I_Imb.
Changes the connectors to PORTA and PORTB, and set up the master slave connections
as shown below.

Add/Edit Hardware Platform Specifications

Peripherals Bus Connections ]F‘orts 1 F‘alame‘ters]

Click on squares to make master, slave or masterslave (M, 5, MS5) connections. Choose one or more {using shiftand Ctr)
Right click on any bus instance {column header) for a context menu. buses and click Add.
X
& b,‘& .;9‘;0 isocm_v10_v1_00_a ~
isocm v10 w1 00 b
isze b ¥ S
mblaze ilmb Ll y opb_w20 v1_10_a
it opb_v20_v1_10b =
mblaze doph A pb_v34 v1_01_a b
mblaze iopb " Choose the BRAM port to connect to the controller port.
gpio_swtz zopb | ¥ Give a name to the conmection.
gpio_leds soph | & Cntlr Port BRAM Port |Connechor
Imb_d_entrl glmb F Imb_d_cnirl bra... |bram1 PORTA Li PORTA
Imb_i_entrl slmb F Imb_i_cntrl bra... bram1PCRTE _:J
jtag_uart zoph 3




Select the Ports tab and enter the values as shown below. Be sure to set the range as [0:7]
for the GPIO_IO ports.

add /Edt Hardware Platform Specifications il
P‘eripharnlal Buz Cannectinns  Foris |F'u.rnme1m]
Pt Sigreal Assigriments. Fipef subsiing orinstance
EE Llse cirl and shiltioe mulipks row selechions and chck Connect b cannect paits.
L5 Ackd Fortfor examal pads hat need 1o be GHDO ar 0
The *Fenge’ calunn for extarnal ports = given os *[LEJB] (for 2.g.[0:31]) Lisi ol Forts. Select one ormore
pors and Cick Add
etace  |PortMame | MatMame |P|:|I... |5mpe 'F.all::l.&ss, Sensty et
PbiEEe  |CLK ays ok 1 e =] CLK e i
midaze | TERRELUFT et god 1 inre.. v e CLE
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moLawts |FI0ID  awh o Bt Zlom wALD INSTR,
who ks [FI00e ki 16 Bt =0T Pe_Ex
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opb CFE_CE sys_ck i = :_] Clls REG_ADDR
= MIR_RES
g [BYERst  sysreset 1 (et = i i
dmb LnE_Ck sys_ck 1 Ext.. ;J Lk Dl PIFE_RLIMNIMG i
divh  |SyeRst  sysreset 1 Bt =l e
I Imb LB Tk ays_ck 1 Ext.. j Lk FREFETCH_ADDOR
]
Umb  |SYS_Rst  sysreset 1 Ext. =) Comngct | | MO e
brami
gpio_swis
OFE_Clk
Dlenaca_|rrr
GRIO_ID
GO0 n
GFO0_d_out
GHO_1_out :J

[ o ]| e | apay L

The final configuration should is shown below. Click Apply when done.

Imstance | PortMame | Met Mame |POI... |Sc0pe |Ra... |Class |Ser‘|sit...
mbilaze CLK sys_cli | Ext. ll CLK

mblaze IMTERRLUFT net_gnd I Inte... ;l IMTER.... LEWVEL...
gpio_swis | GRIO_IO st @] Ext... Ll [0:7]

gpio_leds | GPIO_IO leds I Ext... B [0:7]

opb OPB Ck  sys_ck I Ext. =l LK

opb SYS_Rst Sys_reset I Exti. ;l

dimb  [LMB Ck  sys ck I Ext. =l CLK

d_Imb S5YS_Rst Sys_reset I Extys ;l

i Imb LME Ck sys_ck . B LK

i_Imb SYS_Rst Sys_reset I Ext, ;l




Select Parameters tab. Select gpio_swts and add C_GPIO_WIDTH and change the value
to 8. Repeat the same process with gpio_leds.

dd/Edit Hardware Platform Specifications

Periphemls] Bus Cnnnectiansi Pots  Parameters ]

Edit Parameters assigned to IP Instance in MHS Choose I Instance for a list of paral
These parameter values will overide default MPD values. gpio_leds
Parameters with default values from
Parameter | Value

Choose one or maore {using shift and

€_GPIO_WIDTH s

Parameter Value
C_USER_ID_CODE 3
c C_Dw 32
C_AW |32
<< Add | C_GPIO_WIDTH 2

Click on Apply and OK.

By selecting Project > View Schematic you can be a schematic representation of the
architecture.
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Create a directory “code” in the project directory and save the program

below as system.c in the code directory.

#include "xparameters.h"
#include "xgpio_|.h"
void main(int argc, char *argv[])
{ XGpio_mSetDataDirection(XPAR_GPIO_SWTS BASEADDR, OxFF);
XGpio_mSetDataDirection(XPAR_GPIO_LEDS BASEADDR, 0x00);
while (2)

XGpio_mSetDataReg(XPAR_GPIO_LEDS BASEADDR,
XGpio_mGetDataReg(XPAR_GPIO_SWTS BASEADDR));
}

}

Select the System tab then highlight mblaze.

Ps Xilinx XPS - C:\AMB_Tutorials\T1\ - [system.pbd]
‘File Edit View Project Tools Options Add Window Help

Deuas||szes @ ||aaxEas||

FE  BDD ke ER e R S BE

| — |

System 113516&19 Components l [EmE

Right Click for Options

=k System BSF

- QS ﬂ

® [ebug Perpheral:

[ ¥

& Mode;
® STDIM:

& STDOUT:

i-E Linker Script:

Then select Project > Add Program Sources.

Ps Xilinx XPS - C:\MB_Tutorials\T1\ - [syste
4 File Edit View Ji{i[=«# Tools Options Add \

RN oo souces. |
: 1 Remove File '
S 6 E

Assign Default Drivers



Select system.c in the code directory.

Add Source and Header Files to the current processor E|E|
Lunkln:lﬁm _"_1 = £ EF-

@ system.c

File name:  [system.c Open

Files of type: 1F‘n:ug||am Files I_‘.I:.‘.s.‘.n:c.‘.cpp.‘.u:::o’..*.u:-i—r.‘ﬂ Cancel

Y ou may edit the program within the XPS by selecting system.c under Sources as shown.
psl Xilinx XPS - C:\MB_Tutorials\T1\ - [system.c]

‘ File Edit View Project Tools Options Window Help
DexEdHE S || 2w o [ || R G oW =g mEDO &K
G0 D e ® DR S %o B B |t te | |l
=l
-5 i} 3636 I6 36363636 I 36 36 36 6 36 36 36 36 36 36 36 3636 I 36 I 6 IE I IEIEIEIEIEIEIEIE IS
System ]Ep@cns Componenis ] 01 * Microblaze demostration using the Dic
02 % Cutput= svitches to ILed's.
e 03 = Author: Dr. Jerry H. Tucker
Right Click for Options . - 132103
= 05 % Project: MB _PIO connects switches to
= ] System BSP 2 06 x to port &B or EF of Digilab
= m mblaze . o7 36 36 36 36 36 3636 36 3F 36 36 3F 36 3 IE 36 I 36 36 36 36 3636 36 36 3 36 36 36 36363636 36 3 I 334
#® [ebug Peripheral: 32  Finclude "zparameter=. h"
* Mode: 3  finclude "=gpic 1. h"
* STOIN: 10 woid main{int argc, char *argw[])
; 11
e STDOUT: T
E Linker Script: 13 iGpio_mSetDataDirectioniXPAR _GPIO !
-~ [l Generated Header: mblazeinclude 14 ipio_mSetDatalirection(XPAR GPIO !
= Sources 1; while (1)
& [CAME_TutorialshT 14codehapstem of 17 PN N N N N
[E Headers 18 HGpio_mSetDataReg(XPAR_GPIO LE]
_ I trami = iGpio_mGetDatal
* I cpic_swts 20 T
+ - gpin_leds z; )
=+ Imb_d_cnir oa
-3 b i oot




The .ucf fileis used to map the signal to the appropriate pins of the FPGA.
If necessary create a data directory and add a system.ucf containing the information

shown below.

NET "sys clk" LOC ="P80"; #50 MHz
NET "sys reset" LOC ="P40";  #BTN1 on DIO board
NET "leds<0>" LOC = "P44": #LEDO
NET "leds<1>" LOC = "P46"; #LED1
NET "leds<2>" LOC = "P48"; #LED2
NET "leds<3>" LOC = "P55": #LED3
NET "leds<4>" LOC = "P57"; #LED4
NET "leds<5>" LOC = "P59": #LED5
NET "leds<6>" LOC = "P61"; #LED6
NET "leds<7>" LOC = "P63"; #LED7
NET "swts<0>" LOC = "P16"; #SWTO
NET "swts<1>" LOC = "P18"; #SWT1
NET "swts<2>" LOC = "P21"; #ONT2
NET "swts<3>" LOC = "P23"; #SWT3
NET "swts<4>" LOC = "P27"; #9WT4
NET "swts<5>" LOC = "P30"; #SWT5
NET "swts<6>" LOC = "P33"; #SWT6
NET "swts<7>" LOC = "P35"; #SWT7

Select Tools > Clean - All to delete unneeded files. This step is not necessary the first
time, but may be required if changes are made.
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Using the Tools menu successively select the following: Generate Libraries, Compile
Program Source, Generate Netlist, Generate Bitstream, Update Bitstream.
Alternatively you may successively select the icons shown below.

_Tutorials\T1\ - [system.c] e L=
sject BEEEE Options Window Help

(ICETCEE | | fb: & | o [Hy | B

Compile Program Sources IMII
| | llbt GetProgram Size
Generate BSP for VxWorks

SRR

zenerate Metlist

Generate Bitstream

fick fg Generate SystemACE File
Impart Peripheral Wizard. ..

OO
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Peripl  Download

Clean b
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2 Software Debugger
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At this point the download.bit file has been crated in the implementation directory of the
project.
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With the parallel cable connected between the PC and the DE2 board, start the impact
program. Note: Impact.exeislocated in the directory where the I|SE was installed, usually
at “c:\Xilinx\bin\nt\impact.exe”.

Operation Mode Selection

What do you wart to do first?

" Prepare Configurstion Files
" Load Configuration File {.cdf, pdr)

Mext = Cancel Help

Click on Cancel
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With Boundary-Scan selected, right click to bring up menu and select Add Xilinx Device.
In the project’ s implementation directory, select download.bit.

S Untitled [Configuration Mode] - iMPACT =13
File Edit View Mode Operations Qutput Help

Ded =Rz a% s dEzs0 G

Boundary-Scan | Slave Serial | SelectMAP | Deskton Confinuration |

Add Xilinx Device |

Right click to Add Device or Initialize JTAG chain

Add Device

Look in: J \_=) implementation

Well
ICicache
pi download.bit
dd system. bit
Add a

Type: BIT File
Date Modified: 2/16/2004 2:13 AM
bize: 176 KB

File name: download bit

Files of type: | All Design Files
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Place cursor over Xilinx chip and right click to select program to download the
download.bit file.

2 Untitled [Configuration Mode] - iMPACT
File Edit View Mode Operations Output Help

0w M & B 0 o= 5k on | LEEE | S0 | BN
Boundary-5Scan ]SIave Seriall SelemMAP] Desktop Cunﬁguratiun]

wc2z00e
download.bit

Programming Succeeded

done. -
INFO:MPACT:579 - '1: Completed downloading bit file to device.

INFO:MPACT:580 - '1":.Checking done pin ... .done.

'1': Programmed successfully.

PROGRESS_END - End Operation.

Elapsed time = 7 =ac.

For Help, press F1 Configuration Made Bnundary-Scan F
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